Базовая настройка коммутатора Cisco

Данная статья также подойдет для настройки таких коммутаторов, как Cisco Catalyst 2950, Cisco Catalyst 2960, Cisco Catalyst 3550, Cisco Catalyst 3560, Cisco Catalyst 3560G.

Подключаем устройство через консольный кабель. При первой загрузке устройства мастер установки предложит выполнить пошаговую настройку, отказываемся от этого шага:

Continue with configuration dialog? [yes/no]: no

После чего оказываемся в пользовательский режиме:

Switch>

Переходим в привилегированный режим:

Switch> en
Password:

Вводим пароль и жмем Enter

Switch#

Задаем имя коммутатора – C2960

Switch# configure terminal
Switch(config)# hostname C2960
C2960(config)#

Зададим IP-адрес для интерфейса управления коммутатором.
В моем случае я использую 24 порт коммутатора с управляющим Vlan-ом, в других вариациях можно настроить иные порты.

C2960(config)#vlan 2
C2960(config-vlan)#name ManagementVlan
C2960(config-vlan)#ip address 192.168.200.1 255.255.255.0
C2960(config-vlan)# exit
C2960(config)# exit
C2960(config)#interface GigabitEthernet0/24
C2960(config-if)#switchport access vlan 2
C2960(config-if)#no shutdown
C2960(config-if)# exit
C2960(config)# exit

Альтернативный вариант:

C2960(config)# interface fa0/0
C2960(config-if)# no shutdown
C2960(config-if)# ip address 192.168.200.1 255.255.255.0
C2960(config-if)# exit
C2960(config)# exit

Установим пароль для привилегированного режима

C2960(config)# enable secret pa$$w0rd
C2960(config)# exit
C2960#

Установка пароля может быть выполнена командами password и secret. В первом случае пароль хранится в конфигурационном файле в открытом виде, а во втором — в зашифрованном. Если использовалась команда password, необходимо зашифровать пароли, хранящиеся в устройстве в открытом виде с помощью команды service password-encryption в режиме глобальной конфигурации.

Установим пароль для входа по telnet

C2960(config)# line vty 0 5
C2960(config-line)#password telnet-password

И разрешим вход по telnet:

C2960(config-line)# login
C2960(config)# exit

Зашифруем пароли:

C2960(config)# service password-encryption

Если ошибиться при наборе чего-либо в консоли или ввести команду на русском, то Cisco попробует это отрезолвить, выключим эту особенность, не будем тратить время:

C2960(config)# no ip domain-lookup

Зададим имя домена:

C2960(config)# ip domain-name example-domain.com

Зададим IP-адрес DNS сервера:

C2960(config)# ip name-server 192.168.100.1

Чтобы по команде show logging отображалось нормальное время, а не количество дней и прочее пропишем:

C2960(config)# service timestamps log datetime localtime

Настроим access-list для доступа к свитчу только с указанных IP-адресов:

C2960(config)# ip access-list standard TELNET
C2960(config-std-nacl)# permit 192.168.100.1
C2960(config-std-nacl)# permit 192.168.100.2
C2960(config-std-nacl)# exit

Применим этот access-list:

C2960(config)# line vty 0 5
C2960(config-line)# access-class TELNET in

Зададим timeout активности telnet сессии, по истечении указанного времени, если в консоли ничего не вводилось, то telnet соединение будет автоматически закрываться:

C2960(config-line)# exec-timeout 5 0
C2960(config-line)# exit

Напоследок сохраняемся:

C2960# copy running-config startup-config

или

C2960# wr


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

Unlix © Все права защищены 2019

Копирование материалов с сайта Unlix.ru без указания полной ссылки на источник ЗАПРЕЩЕНО!