Как обновить только один пакет в Ubuntu / Debian

Как обновить только один пакет в Ubuntu / Debian

Как обновить только один пакет, используя apt в Ubuntu / Debian / Linux Mint?

Обычно, самым распространенным способом обновления пакетов является запуск команды apt upgrade. Но проблема заключается в том, что все установленные пакеты будут обновлены до последних версий, доступных в настроенных репозиториях. А что, если Вы хотите обновить только один пакет с помощью apt на хосте с Ubuntu или Debian?

Это пригодится, если Вы боитесь поломать все пакеты из-за обновления всего.

Обновить только один пакет в Ubuntu / Debian с помощью apt

Чтобы обновить конкретный отдельный пакет с помощью apt в любой системе на основе Ubuntu / Debian, используйте опцию —only-upgrade:

# apt install --only-upgrade package

Где package — имя пакета, который вы хотите обновить. Это будет работать для всех систем Ubuntu, Debian и Linux Mint.

Приведем пример обновления пакета curl:

# apt install --only-upgrade curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libcurl4
The following packages will be upgraded:
curl libcurl4
2 upgraded, 0 newly installed, 0 to remove and 137 not upgraded.
Need to get 597 kB of archives.
After this operation, 2,048 B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://security.debian.org buster/updates/main amd64 curl amd64 7.64.0-4+deb10u2 [265 kB]
Get:2 http://security.debian.org buster/updates/main amd64 libcurl4 amd64 7.64.0-4+deb10u2 [332 kB]
Fetched 597 kB in 5s (121 kB/s)
Reading changelogs... Done
(Reading database ... 314016 files and directories currently installed.)
Preparing to unpack .../curl_7.64.0-4+deb10u2_amd64.deb ...
Unpacking curl (7.64.0-4+deb10u2) over (7.64.0-4+deb10u1) ...
Preparing to unpack .../libcurl4_7.64.0-4+deb10u2_amd64.deb ...
Unpacking libcurl4:amd64 (7.64.0-4+deb10u2) over (7.64.0-4+deb10u1) ...
Setting up libcurl4:amd64 (7.64.0-4+deb10u2) ...
Setting up curl (7.64.0-4+deb10u2) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10) ...

Теперь Вы знаете, как обновить только один пакет, используя apt в Ubuntu / Debian / Linux Mint и других линукс-дистрибутивах на их основе.


Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.


Unlix © Все права защищены 2021

Копирование материалов с сайта Unlix.ru без указания полной ссылки на источник ЗАПРЕЩЕНО!