Как установить Cisco Packet Tracer на Debian 10

В этой статье мы рассмотрим как установить последнюю версию Cisco Packet Tracer 7.2.2 (на данный момент) на дистрибутив Debian 10. А так же разберем некоторые проблемы при установке и их решение.

Установка Cisco Packet Tracer на Debian (или Ubuntu)

Дла начала Вам нужно скачать Cisco Packet Tracer 7.2.2

Открываем терминал, переходим в директорию с скачанным файлом и делаем его исполняемым

$ chmod +x PacketTracer-7.2.2-ubuntu-setup.run

Запускаем установку

$ ./PacketTracer-7.2.2-ubuntu-setup.run

Установка проста. Жмем Next, Next, принимаем условия использования ПО и снова Next, потом Install. Вводим пароль пользователя с правами root. Через несколько секунд установка будет закончена и остается нажать Finish. Находим в системе ярлык Cisco Packet Tracer и запускаем его. Или же в терминале можно запустить так:

$ packettracer

Если все установилось правильно и всех компонентов хватает (обычно так на Ubuntu), то увидите окно программы

Жмем ОК и попадаем на страницу авторизации. Там можно зайти по учетным данным Cisco или как гость (Guest Login)

Поздравляю. Если Вы запускаете Cisco Packet Tracer, но ничего не происходит… читайте дальше.

Возможные проблемы

error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Если после запуска ничего не происходит, скорее всего у Вас описанная выше ошибка. Чтобы проверить попробуйте из терминала выполнить

$ /opt/pt/bin/PacketTracer7

Необходимо скачать и установить пакет с недостающей библиотекой. Но сначала установим зависимость

$ sudo apt-get install multiarch-support

А теперь скачаем баблиотеку и установим

$ cd /tmp
$ wget http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
$ sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

Возможно при установке вы словите следующую ошибку

unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
Errors were encountered while processing:
libpng12-0_1.2.50-2+deb8u3_amd64.deb

Делаем так

$ sudo mkdir cpt; sudo dpkg -x libpng12-0_1.2.50-2+deb8u3_amd64.deb ./cpt
$ sudo cp ./cpt/lib/x86_64-linux-gnu/libpng12.so.0 /opt/pt/bin/

И теперь все должно запуститься. Пробуем

$ packettracer

Иногда не хватает пакета libqt5webkit5

Чтобы установить, делаем так

$ sudo apt-get install libqt5webkit5


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.


Unlix © Все права защищены 2020

Копирование материалов с сайта Unlix.ru без указания полной ссылки на источник ЗАПРЕЩЕНО!