Как убрать ошибку «doesn’t support architecture i386» при обновлении Debian / Ubuntu

Как убрать ошибку "doesn’t support architecture i386" при обновлении Debian / Ubuntu

Если помимо основной архитектуры (обычно amd64) у Вас используется i386, но какой-либо пакет ее не поддерживает, Вы увидите ошибку «doesn’t support architecture i386» при обновлении. Рассмотрим как просто от нее избавиться.

Первый вариант: отключить поддержку i386

Если Вы не используете пакеты, которые поддерживают i386, можно отключить их поддержку командой:

# dpkg --remove-architecture i386

Если этот вариант не подходит, переходим к следующему.

Второй вариант: указать использование только amd64

Как убрать ошибку "doesn’t support architecture i386" при обновлении Debian / UbuntuКогда ошибка «doesn’t support architecture i386» появляется, Вы можете заметить в этой же строке при обновлении (или установке) из-за какого пакета это происходит. Если это пакет из стандартного репозитория, значит нужно перейти в общий файл с репозиториями /etc/apt/sources.list

Если же это какой-то сторонний репозиторий, то открываем файл с ним (обычно он находится в /etc/apt/sources.list.d/)

А теперь необходимо между deb и https:// вставить [arch=amd64]

Например:

deb [arch=amd64] http://as-repository.openvpn.net/debian bionic focal main

Сохраняем файл. Делаем apt update (apt-get update) и устанавливаем или обновляем что нужно. Ошибки «doesn’t support architecture i386» больше не должно быть.

Эта инструкция может пригодиться на всех ОС Linux основанных на Debian: Ubuntu, Linux Mint, Kali Linux, Proxmox и так далее.


Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.


Unlix © Все права защищены 2021

Копирование материалов с сайта Unlix.ru без указания полной ссылки на источник ЗАПРЕЩЕНО!